- create vrf & apply to interfaces
- create ip vrf by command
- ip vrf A in global mode
- Route Distinguishers
- goal is to make the prefix unique in entire mpls network
- formate of RD changed based on service provider
- AS followed by locally significant number
- router-id followed by locally significant number
- rd config
- rd 200:1 /** config under ip vrf A
- rd 200:2
- apply vrfs to interfaces
- int e0/0
- ip vrf forwarding A
- ip address 1.1.1.1 255.255.255.0 /** reenter ip add because enabling of vrf on interface remove the ip add of the interface
- sh ip route /*** global routing table shows the separate tables for the each customer
- sh route | in interface | in ip address
- under the igp process enable seperate address family
- router eigrp /**under given igp route process
- address-family ipv4 vrf A
- sh ip vrf detail
- sh ip route vrf * /** sh all vrf routing tables
- address-family ip v4 vrf / vpv4
Saturday, April 14, 2012
config b/n PE to CE
MPLS configuration
- MPLS also called Dynamic Label Switching
- Before configuring first enable the CEF
- command used is ip cef in global mode
- Verify by show command show ip cef
- It increases the packet switching speed.
- main
- Enable MPLS forwarding of ipv4 packets along the routed paths( also called Dynamic Label Switching
- must be enable on interface & device
- command: mpls ip
- unique router-id important in MPLS
- As a router-id loopback address is more advantage than interface address
- command used to router-id as loopback is
- mpls ldp router-id loopback0 force
- In sometimes loopback ip address used as router-id cannot be reachable
- at that time an interface is used as router-id, to this use the following command under interface
- mpls ldp discovery transport-address interface
- enable mpls on routing protocol enabled interfaces
- mpls ldp autoconfig under routing process.
- enable mpls authentication globally.
- mpls ldp password required in global mode
- mpls ldp neighbour 150.1.5.55 password CISCO
- to show mpls neighbours
- show mpls ldp neighbors
- to show mpls enabled interfaces
- show mpls interfaces
- to show mpls authentication
- show mpls ldp neighbor password
- to show LFIB table
- show mpls forwarding-table
- to check the packets are forwarding by MPLS
- traceroute 150.1.5.5
- normally LDP will generate & adverties labels for every prefix found in the local routing table
- to avoid this & enable only on some prefixes uses the access control list
- exampls:
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10
- PE configuration
- in mpls network full mesh of PEs was created using ibgp peerings
- for example
neighbor 155.1.5.5 remote-as 1oopback0
neighbor 155.1.5.5 update-source loopback0
address-family vpv4 unicast /** activating vpv4 address family
neighbor 150.1.5.5 activate
neighbor 150.1.5.5 send-community extended
neighbor 150.1.5.5 route-reflector-client
- to define VRF use command
- ip vrf vrf-name
Subscribe to:
Posts (Atom)